侧边栏壁纸
博主头像
慢行的骑兵博主等级

贪多嚼不烂,欲速则不达

  • 累计撰写 29 篇文章
  • 累计创建 27 个标签
  • 累计收到 1 条评论

目 录CONTENT

文章目录

Flutter实战记录-协作开发遇到的问题

慢行的骑兵
2024-05-07 / 0 评论 / 0 点赞 / 50 阅读 / 272 字

一.前言

  • Android项目使用了混合架构,部分模块使用Flutter进行开发。在电脑A上开发的项目提交到git仓库,电脑B拉取后进行操作,遇到两个问题,特此做一下记录;

二.问题A

  • Settings file ‘D:\xxx\settings.gradle’ line: 84
  • D:\xxx.android\include_flutter.groovy
  • 报错信息如截图所示
    报错1
  • 根据报错信息可以知道,是因为flutter模块下的.android文件夹不存在。尝试在提交代码时候,将flutter的.gitignore中的.android/和.ios/不要进行配置,可以处理问题A;

三.问题B

  • ‘packages/flutter_tools/gradle/module_plugin_loader.gradle’ as it does not exit
  • 报错信息如截图所示
    报错2
    +初步推测,跟Flutter sdk等有关系;环境统一,估计该问题就可以解决;

四.总结

  • 针对类似的场景,以上两个问题,可以通过一个命令来进行解决,在flutter模块下执行命令:flutter create .
  • 未执行命令前:
    执行命令
  • 执行命令后:
    执行命令后
0

评论区